Are you first timer at lazacode.org? Why not join us and start exchange your programming knowledge with everyone. Register today!

Wamp server - fix installation issue on windows (Microsoft Visual C++ Redistributable dependencies)

0 votes
84 views
added Mar 28 in Server issues by LC Marshal Captain (23,940 points)
edited Mar 28 by LC Marshal

 

the code execution cannot proceed because msvcr110.dll
the code execution cannot proceed because VCRUNTIME140.dll

Tips

  1. Both error message are showing during windows installation, specifically for new-installed windows OS.
  2. You'll get prompt message prior installation from wamp for all missing Microsoft Visual C++ Redistributable dependencies files.
  3. Download and installed all of them. (Regardless x64 or x86)
    1. List of item to be installed
    2. --- Visual C++ Packages ---
      The MSVC runtime libraries VC9, VC10, VC11 are required for Wampserver 2.4, 2.5 and 3.0, even if you use only Apache and PHP versions with VC11. Runtimes VC13, VC14 is required for PHP 7 and Apache 2.4.17 or more
      -- VC9 Packages (Visual C++ 2008 SP1)
      http://www.microsoft.com/en-us/download/details.aspx?id=5582
      http://www.microsoft.com/en-us/download/details.aspx?id=2092
      -- VC10 Packages (Visual C++ 2010 SP1)
      http://www.microsoft.com/en-us/download/details.aspx?id=8328
      http://www.microsoft.com/en-us/download/details.aspx?id=13523
      -- VC11 Packages (Visual C++ 2012 Update 4)
      The two files VSU4\vcredist_x86.exe and VSU4\vcredist_x64.exe to be download are on the same page: http://www.microsoft.com/en-us/download/details.aspx?id=30679
      -- VC13 Packages Update 5(Visual C++ 2013)
      The two files VSU4\vcredist_x86.exe and VSU4\vcredist_x64.exe to be download are on the same page: https://support.microsoft.com/en-us/help/4032938/
      -- VC14 Packages (Visual C++ 2015 Update 3) Supersedes by VC15
      - VC15 Redistribuable (Visual C++ 2017)
      https://aka.ms/vs/15/release/VC_redist.x86.exe
      https://aka.ms/vs/15/release/VC_redist.x64.exe
      VC2017 (VC15) is backward compatible to VC2015 (VC14). That means, a VC14 module can be used inside a VC15 binary. Because this compatibility the version number of the Redistributable is 14.1x.xx and after you install the Redistributable VC2017, VC2015 is removed but you can still use VC14.

      If you have a 64-bit Windows, you must install both 32 and 64bit versions of each VisualC++ package, even if you do not use Wampserver 64 bit
      To verify that all VC ++ packages are installed and with the latest versions, you can use the tool:
      http://wampserver.aviatechno.net/files/tools/check_vcredist.exe and you will find all the packages on http://wampserver.aviatechno.net/ in section Visual C++ Redistribuable Packages
      You must install each package "as an administrator", so right-click the exe file and then run as Administrator. Do not use a previously loaded tool. Make a new download to make sure you are using the correct version.

 

 

Please log in or register to response this reference.

lazacode.org - Malaysia's programming knowledge sharing platform, where everyone can share their finding as reference to others.
...